PHP Developers Network

A community of PHP developers offering assistance, advice, discussion, and friendship.
 
Loading
It is currently Thu Dec 14, 2017 11:58 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: Ruby on shared hosting
PostPosted: Thu May 28, 2015 7:49 pm 
Offline
Forum Newbie

Joined: Tue Mar 11, 2014 9:35 pm
Posts: 14
Folks,

I am trying to run a Ruby file through PHP on a shared hosting site. Basically, I created the .rb file, then used PHP chmod to change the permissions to 755; however, I am not getting anything out of it. The reason for wanting to run Ruby code is so I can use the language capabilities, such as: threads, XML and PDF creating/manipulating gems. I am writing a site for a friend's business and I want to create an administrative section that will generate periodic reports of estimates, contacts, etc. Thanks in advance for your help and understanding.


Top
 Profile  
 
PostPosted: Thu May 28, 2015 7:58 pm 
Offline
Moderator
User avatar

Joined: Tue Nov 09, 2010 3:39 pm
Posts: 6402
Location: Montreal, Canada
Have you checked that Ruby is installed on the shared host? There's also a good chance that shell_exec is disabled. Shared hosting might not be a great fit here, or you'd need alternatives to what you're currently trying to accomplish with Ruby.

_________________
Supported PHP versions No longer supported versions


Top
 Profile  
 
PostPosted: Fri May 29, 2015 5:25 pm 
Offline
Forum Newbie

Joined: Tue Mar 11, 2014 9:35 pm
Posts: 14
Well, according to the ISP their shared hosting provides Ruby support. In fact, they advertise it as part of their shared business hosting packages. The problem I am having is that their help options and/or forums do not provide much info other than the basic instructions on how to login and install gems via SSH and even that is a little buggy. I tried installing a gem a few days ago and got a message letting me know that I did not have permissions to write to a certain folder--do not remember which right now, which I am assuming is the folder where the gems are stored at. I even tried creating an .rb and .cgi file in both the root directory and the cgi-bin and tried to run those and nothing. What do you suggest?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group