PHP Developers Network

A community of PHP developers offering assistance, advice, discussion, and friendship.
 
Loading
It is currently Sun Jun 07, 2020 4:34 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 13 posts ] 
Author Message
PostPosted: Sat Jun 20, 2009 2:09 am 
Offline
DevNet Resident
User avatar

Joined: Wed Jun 18, 2008 8:32 am
Posts: 1483
Location: Surrey
For some reason the same code on my production server is getting slashes added, but magic quotes are off on dev and live.

Any ideas what it could be?


Top
 Profile  
 
PostPosted: Sat Jun 20, 2009 5:42 am 
Offline
Forum Newbie

Joined: Sat Jun 20, 2009 4:58 am
Posts: 9
Try to have a look if for some reason magic quotes gets enabled "locally" instead of server-wide.


Top
 Profile  
 
PostPosted: Sat Jun 20, 2009 1:03 pm 
Offline
DevNet Resident
User avatar

Joined: Wed Jun 18, 2008 8:32 am
Posts: 1483
Location: Surrey
Nope, looks fine.

Plus it works fine on my dev server (the exact same code) which is pretty much the same - but obviously a small difference, just cant figure out what it is :?

Does anything else control addslashes?


Top
 Profile  
 
PostPosted: Sat Jun 20, 2009 1:30 pm 
Offline
DevNet Master
User avatar

Joined: Fri Jan 18, 2008 1:36 am
Posts: 3549
Location: Israel, ME
Run this just before you run the code that is under suspicion to make sure:
Syntax: [ Download ] [ Hide ]
var_dump( get_magic_quotes_runtime() );
var_dump( get_magic_quotes_gpc() );


Top
 Profile  
 
PostPosted: Sun Jun 21, 2009 2:02 am 
Offline
DevNet Resident
User avatar

Joined: Wed Jun 18, 2008 8:32 am
Posts: 1483
Location: Surrey


Top
 Profile  
 
PostPosted: Sun Jun 21, 2009 2:36 am 
Offline
DevNet Master
User avatar

Joined: Fri Jan 18, 2008 1:36 am
Posts: 3549
Location: Israel, ME
It means that magic_quotes is on, either via the php.ini or via .htaccess. find it and destroy it


Top
 Profile  
 
PostPosted: Sun Jun 21, 2009 12:34 pm 
Offline
DevNet Resident
User avatar

Joined: Wed Jun 18, 2008 8:32 am
Posts: 1483
Location: Surrey
I just cant find it. Nothing in php.ini or .htaccess files

The only difference between my 2 servers is that my live server is using plesk.


Top
 Profile  
 
PostPosted: Sun Jun 21, 2009 3:31 pm 
Offline
DevNet Master
User avatar

Joined: Fri Jan 18, 2008 1:36 am
Posts: 3549
Location: Israel, ME


Top
 Profile  
 
PostPosted: Sun Jun 21, 2009 11:33 pm 
Offline
DevNet Resident
User avatar

Joined: Wed Jun 18, 2008 8:32 am
Posts: 1483
Location: Surrey


Top
 Profile  
 
PostPosted: Sun Jun 21, 2009 11:41 pm 
Offline
DevNet Resident
User avatar

Joined: Wed Jun 18, 2008 8:32 am
Posts: 1483
Location: Surrey
My next dedicated will be pure linux and no plesk. :wink:


Top
 Profile  
 
PostPosted: Tue Jun 23, 2009 3:19 am 
Offline
DevNet Resident
User avatar

Joined: Wed Jun 18, 2008 8:32 am
Posts: 1483
Location: Surrey
I could not find the little s**t!

I have just turned off magic quotes in the .htaccess file - probably best as it wont give me issues server to server.


Top
 Profile  
 
PostPosted: Tue Jun 23, 2009 4:24 am 
Offline
DevNet Master
User avatar

Joined: Wed Jun 27, 2007 9:44 am
Posts: 4313
Location: Sofia, Bulgaria

_________________
There are 10 types of people in this world, those who understand binary and those who don't


Top
 Profile  
 
PostPosted: Tue Jun 23, 2009 7:36 am 
Offline
DevNet Resident
User avatar

Joined: Wed Jun 18, 2008 8:32 am
Posts: 1483
Location: Surrey
I did, but it took too long so stopped it.

But I should leave it running to find out where the issue is.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 13 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 12 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group