PHP Developers Network

A community of PHP developers offering assistance, advice, discussion, and friendship.
 
Loading
It is currently Sat Dec 16, 2017 2:17 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 1 post ] 
Author Message
PostPosted: Wed Jan 18, 2012 9:52 am 
Offline
Forum Commoner

Joined: Sun Feb 24, 2008 12:01 pm
Posts: 39
Hi,

Today I checked my registration script which sends out a confirmation email and noticed a warning:

Quote:
Warning: The magic method __call() must have public visibility and cannot be static in /home/gigme77/public_html/lib/classes/Swift/Transport/EsmtpTransport.php on line 213


But the emails are at least delivered.

So I thought that it may be because I was using an older version of
the library and something has changed.

So I downloaded the latest version: 4.1.5 and uploaded
the lib directory to my server.

Now I get a worse result:

Quote:
Fatal error: Uncaught exception 'Swift_TransportException' with message 'Failed to authenticate on SMTP server with username "james.gigme77" using 2 possible authenticators' in /home/gigme77/public_html/lib/classes/Swift/Transport/Esmtp/AuthHandler.php:176 Stack trace: #0 /home/gigme77/public_html/lib/classes/Swift/Transport/EsmtpTransport.php(307): Swift_Transport_Esmtp_AuthHandler->afterEhlo(Object(Swift_SmtpTransport)) #1 /home/gigme77/public_html/lib/classes/Swift/Transport/AbstractSmtpTransport.php(124): Swift_Transport_EsmtpTransport->_doHeloCommand() #2 /home/gigme77/public_html/lib/classes/Swift/Mailer.php(79): Swift_Transport_AbstractSmtpTransport->start() #3 /home/gigme77/public_html/send_email.php(67): Swift_Mailer->send(Object(Swift_Message), Array) #4 /home/gigme77/public_html/index.php(181): require('/home/gigme77/p...') #5 {main} thrown in /home/gigme77/public_html/lib/classes/Swift/Transport/Esmtp/AuthHandler.php on line 176

Why is this ?
The user name is valid ... it worked fine with the previous /lib

In fact I have swapped them back and forth to check and I get the same results
without ANY change to my calling script.

I have looked at the usage of the classes and nothing appears to have
changed radically.

Have I missed something ?

How can I fix this ?

Thanks.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group