PHP Developers Network

A community of PHP developers offering assistance, advice, discussion, and friendship.
 
Loading
It is currently Sun May 31, 2020 2:47 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 4 posts ] 
Author Message
PostPosted: Mon Oct 05, 2015 3:00 pm 
Offline
Forum Contributor
User avatar

Joined: Wed May 14, 2014 12:18 pm
Posts: 331
I had a requirement in laravel, where i needed to some server side cropping using the the laravel package Imagine, now i followed the installation instruction for this package for my application, I.E. :

I added the below line in my composer.json file:

Syntax: [ Download ] [ Hide ]
{
    "require": {
        "orchestra/imagine": "~3.0"
    }
}
 


My composer.json file looks like below now:

Syntax: [ Download ] [ Hide ]
{
    "name": "laravel/laravel",
    "description": "The Laravel Framework.",
    "keywords": ["framework", "laravel"],
    "license": "MIT",
    "require": {
        "laravel/framework": "4.2.*",
        "intervention/image": "dev-master",
        "orchestra/imagine": "~3.0"
    },
    "autoload": {
        "classmap": [
            "app/commands",
            "app/controllers",
            "app/models",
            "app/database/migrations",
            "app/database/seeds",
            "app/tests/TestCase.php"
        ]
    },
    "scripts": {
        "post-install-cmd": [
            "php artisan clear-compiled",
            "php artisan optimize"
        ],
        "post-update-cmd": [
            "php artisan clear-compiled",
            "php artisan optimize"
        ],
        "post-create-project-cmd": [
            "php artisan key:generate"
        ]
    },
    "config": {
        "preferred-install": "dist"
    },
    "minimum-stability": "stable"
}
 


Now when i run composer update from the terminal , i get the following messages:



and i have now followed THESE INSTRUCTIONS too, of adding the alias etc to the config/app.php,

Now when i try to load my admin panel , i get the following error:

Syntax: [ Download ] [ Hide ]
Class 'Orchestra\Imagine\ImagineServiceProvider' not found
 


Why am i getting this error , can somebody explain ?


Top
 Profile  
 
PostPosted: Mon Oct 05, 2015 3:21 pm 
Offline
Moderator
User avatar

Joined: Tue Nov 09, 2010 3:39 pm
Posts: 6425
Location: Montreal, Canada
Syntax: [ Download ] [ Hide ]
    "require": {
        "laravel/framework": "4.2.*",
        "intervention/image": "dev-master",
        "orchestra/imagine": "~3.0"
    },


https://github.com/orchestral/imagine#v ... patibility

_________________


Top
 Profile  
 
PostPosted: Tue Oct 06, 2015 12:20 am 
Offline
Forum Contributor
User avatar

Joined: Wed May 14, 2014 12:18 pm
Posts: 331
"require": {
"laravel/framework": "4.2.*",
"intervention/image": "dev-master",
"orchestra/imagine": "~3.0"
},

Thats exactly what i have :D


Top
 Profile  
 
PostPosted: Tue Oct 06, 2015 12:28 am 
Offline
Forum Contributor
User avatar

Joined: Wed May 14, 2014 12:18 pm
Posts: 331
Ohh ok , got it :D , thanks celauran :) updated composer.json to below now :

"require": {
"laravel/framework": "4.2.*",
"intervention/image": "dev-master",
"orchestra/imagine": "~2.2"
},


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group