PHP Developers Network

A community of PHP developers offering assistance, advice, discussion, and friendship.
 
Loading
It is currently Tue Sep 22, 2020 9:41 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 8 posts ] 
Author Message
 Post subject: CHESS SITE
PostPosted: Thu Apr 30, 2015 6:22 pm 
Offline
Forum Regular
User avatar

Joined: Fri Sep 05, 2008 3:34 pm
Posts: 539
Location: Victoria, BC
My has several pages that are assembled with PHP

for some reason, the dialogs series of .... are changed into some unknown symbol and I cannot figure out why

i have tried careful code checking, was working but then it stopped with no changes outside more games played

here is a link to the for comparison


Top
 Profile  
 
 Post subject: Re: CHESS SITE
PostPosted: Thu Apr 30, 2015 8:25 pm 
Offline
Spammer :|
User avatar

Joined: Wed Oct 15, 2008 2:35 am
Posts: 6617
Location: WA, USA
So those are supposed to be dots? group1.php is using the UTF-8 encoding but the dots are in ISO 8859-1. (The group1.html page is using the latter so it appears correctly.)

I suspect is't the "ANSI" charset you're using. I'm not even sure that's a valid name for it. Use
Syntax: [ Download ] [ Hide ]
<meta http-equiv="Content-Type" content="text/html;charset=ISO-8859-1">
<meta charset="ISO-8859-1">


Top
 Profile  
 
 Post subject: Re: CHESS SITE
PostPosted: Sat May 02, 2015 11:07 am 
Offline
Forum Regular
User avatar

Joined: Fri Sep 05, 2008 3:34 pm
Posts: 539
Location: Victoria, BC
I have tried that, same problem

I was able to partially fix it with a hard coded & code, but the .. was not fixed, only the isolated ones

I have even tried using a <font> to force the issue, no such luck


Top
 Profile  
 
 Post subject: Re: CHESS SITE
PostPosted: Sat May 02, 2015 8:27 pm 
Offline
Spammer :|
User avatar

Joined: Wed Oct 15, 2008 2:35 am
Posts: 6617
Location: WA, USA
Could be the output itself is wrong. What's the code there look like?


Top
 Profile  
 
 Post subject: Re: CHESS SITE
PostPosted: Sun May 03, 2015 6:57 am 
Offline
Forum Regular
User avatar

Joined: Fri Sep 05, 2008 3:34 pm
Posts: 539
Location: Victoria, BC
Syntax: [ Download ] [ Hide ]

<html lang="en">

<head>
<meta content="en-us" http-equiv="Content-Language">
<meta http-equiv="Content-Type" content="text/html;charset=ISO-8859-1">
<link href="http://computer-chess.azurewebsites.net/css/images.css" rel="stylesheet" type="text/css">
<link href="http://computer-chess.azurewebsites.net/css/styles.css" rel="stylesheet" type="text/css">
<link href="http://computer-chess.azurewebsites.net/css/tables.css" rel="stylesheet" type="text/css">
<!-- <script src="http://computer-chess.azurewebsites.net/js/general.js" type="text/javascript"></script> -->
<!-- <script src="http://computer-chess.azurewebsites.net/js/advertisement.js" type="text/javascript"></script> -->
<meta content="900" http-equiv="refresh">
<title>Computer Chess: Tournaments</title>
</head>

<body id="body">

<!-- Header block --><?php include $_SERVER["DOCUMENT_ROOT"] . "/menu.php"; ?>
<h1>CHESS TOURNAMENTS</h1>
<?php include $_SERVER["DOCUMENT_ROOT"] . "/tournaments/group-body.php"; ?> <!-- the top body part -->
<?php include $_SERVER["DOCUMENT_ROOT"] . "/tournaments/html/group1.html"; ?> <!-- Arena conveniently formats results -->
<?php include $_SERVER["DOCUMENT_ROOT"] . "/footer.php"; ?> <!-- Footer block, legals etc -->

</body>

</html>


 


Top
 Profile  
 
 Post subject: Re: CHESS SITE
PostPosted: Sun May 03, 2015 7:30 am 
Offline
Spammer :|
User avatar

Joined: Wed Oct 15, 2008 2:35 am
Posts: 6617
Location: WA, USA


Top
 Profile  
 
 Post subject: Re: CHESS SITE
PostPosted: Sun May 03, 2015 8:57 am 
Offline
Forum Regular
User avatar

Joined: Fri Sep 05, 2008 3:34 pm
Posts: 539
Location: Victoria, BC
nothing like that noticed and that is something that recently has been changed


I will inquires over in the Azure forum, maybe somebody over there has some ideas?

Thanks for looking, did not think my code as borked, seems pretty basic


Top
 Profile  
 
 Post subject: Re: CHESS SITE
PostPosted: Sun May 03, 2015 6:58 pm 
Offline
Forum Regular
User avatar

Joined: Fri Sep 05, 2008 3:34 pm
Posts: 539
Location: Victoria, BC
I have figured out the problem, the PHP 5.6 is the problem, setting it back to 5.4 and the page rendered as expected

so I have brought this to the attention of the host, Microsoft Azure so that they can fix it, as I am now more confident my page is LEGAL and valid

I have had to add some PHP code to the page template to override the headers that are being imposed on me

Syntax: [ Download ] [ Hide ]
<?php header('Content-Type: text/html; charset=ISO-8859-1'); ?>


I simply added this to the top of each page before the HTML tag, which now seems to work as desired

I fixed this post with the solution in case anyone else has been experiencing problems with older content that is not necessarily UTF-8 friendly etc

I am using PHP for document assembly so I have to graunch it with a header override, in my opinion that is a problem as negates the header already present in the HTML


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group